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TEXERCISE OF CREATING DATABASE 

Exercise 1:  Create database “ACCESS_DB”. 
 

1. make sure your task pane is showing. If it isn’t, go to the View menu and  select 
Task Pane (or press [Ctrl] [F1]).  

2.  From the list of options in the task pane, click   (you can also 
click  the icon on the toolbar).  

3.  From the new list of options which appears, click  
4.  For the file location, select (or create) and appropriate folder in your      

student drive. Type “ACCESS_DB” for the file name and click Create. 
5. Than after “Database window” will appear. 
 

Exercise 2:  Create table “student” in Design View. 
1. In the Database window click on . 
2.  The table design window will look similar to the one below. 
3. Create a Table in Design View using following structure. 
 

Student :table 
FieldName Data Type Description 
s_id Number student's id will automatically gnerated by Access 
s_no Number student number 
s_name Text student name 
s_address Memo full address of student 
phone Text Phone number of student 

 
4. Click on “Save” Button on toolbar OR ctrl+S 
5. In Save As dialogbox , type “student” in Table Name textbox. 
 

 
 
6. Than Access will ask to set  primary key.In following Dialog box click on No. 

 

 
 
7. Close the design view of the table.  
8. Reopen “student” table in design for additional fields. 
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9. Add the fields using following structure. 
 

Student :table 
FieldName Data Type Description 
birthdate Date/Time Student’s birthdate 
email_id Hyperlink Email id of student 
photo OLE Object Photo of student 
City Lookup Wizard City of  student 
state Text State of student 

 
 Step to insert OLE Object in photo field 

 Open table in datasheet  view. 
 Right click on photo field  
 Click on insert object option 
 In appeared dialog box select “Select From File “ option button. 
 Click on browse button and select appropriate path for your image. 
 Click on ok button. 

 
 Step of Lookup wizard in city field 

 Select datatype Lookup Wizard and then press Enter. 
 Choose second option button  “ I will type the value that I want” then click 

“next”. 
 Type your city name list under “Col1” column Like 

Bombay,Pune,Junagadh,Rajkot…... 
 Click next . 
 Write label for your lookup column. 
 Click Finish. 

 
Exercise 3 : Entering data in Table. 
 

1. open table in Datasheet View and Enter following record in it. 
 

s_id s_no s_name S_addres
s 

phone birthdate email_id photo city state 

1 1001 Patel 
Liza  

M.G. 
Road 

02852630633 09/09/87 Liza@gmail
.com 

Package Junagadh GUJ 

 
 
Exercise 4 : Creating  Primary Key   
 

1. Open “student” table in Design view. 
2. Right click on row of  “s_id” field  . 
3. From the pop up menu select Primary key option.  
Note :  We can also set primary key,From the Edit menu select Primary Key. A key symbol 
will appear next to that field.  
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Exercise 5 : Create another tables “student_fees” and “sports_detail”in 
Design view from following structure. 
 
student_fees :table 
FieldName Data Type Description 
s_id Number student's id will automatically gnerated by Access 
s_fees Currency Fees of student 
pay_date Date / Time  Date of payment 
 

Note : set Primary Key on “s_id” field. 
 

sports_detail :table 
FieldName Data Type Description 
s_id Number student's id will automatically gnerated by Access 
sports_id Text Sports ID 
game_played Text  Name of Game 
duration_hour Text Hours of Game 
playing_date Date / Time Date of playing 
 
 
Exercise 6 : Defining a Relationship 
 

 One to One Relationship 
 

1. Right click on blank area of Database Window  select Relationship. 
2. Right click on Relationship Window  select Show Table. 
3. Select “student” and “student_fees” tables from Show Table Dialogbox. 
4. “s_id” field of “student” table drag and drop on “s_id” field of “student_fees” table 
5. then Edit relationship dialogbox will appear. 

 

 
 
6. In it select three check boxes  

 Enforce Referential Integrity 
 Cascade Update Related Fields 
 Cascade Delete Related Records 

Note : In this dialogbox you will see the type of Relationship at bottom. 
7. click on create button. 
8. Close the relationships window. When you are prompted to save the changes, click Yes. 
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 One to many Relationship 
 

1. Right click on blank area of Database Window  select Relationship. 
2. Right click on Relationship Window  select Show Table. 
3. Select “student” and “sports_detail” tables from Show Table Dialogbox. 
4. “s_id” field of “student” table drag and drop on “s_id” field of “sports_detail” table 
5. then Edit relationship dialogbox will appear. 

 

 
 
6. In it select three check boxes  

 Enforce Referential Integrity 
 Cascade Update Related Fields 
 Cascade Delete Related Records 

Note : In this dialogbox you will see the type of Relationship at bottom. 
7. click on create button. 
8. Close the relationships window. When you are prompted to save the changes, click Yes. 
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Exercise 7 : Record Entry   
 

student : Table 
S_id s_no NAME s_address phone birthdate email_id photo city state 
2 1002 Rayja 

Naitik 
Yagnik 
Road 

02812678
652 

2/4/88 HTUNaitik_R@
gmail.comUTH 

Package Rajkot GUJ 

3 1003 Mehta 
Pratham 

Galaxy 
Chowk 

02812699
512 

3/8/04 HTUMehta_P@r
ediff.comUTH 

Package Rajkot GUJ 

4 1004 Doshi 
Darshil 

Ring Road 02842349
877 

9/10/87 HTUDoshi_dd@
yahoo.comUTH 

Package Pune MHA 

5 1005 Joshi 
Kriya 

Rani Para 
Road 

02792789
129 

9/8/87 HTUJoshi_k@g
mail.comUTH 

Package Kattani MP 

6 1006 Shah 
Lipsa 

Raiya 
Road 

02312989
877 

5/3/82 HTUShah_l@red
iif.comUTH 

Package Delhi UP 

7 1007 Sharma 
Pratik  

Cross 
Road 

02612349
879 

1/1/79 HTUPartik_s@y
ahoo.comUTH 

Package Bombay MHA 

8 1008 Vyas 
Nija 
 

Challa 
Road 

02892773
344 

3/7/86 HTUNija_V@g
mail.comUTH 

Package Kotta RST 

9 1009 Vora 
Krutika 

University 
Road 

02762339
955 

2/6/86 HTUVora_smit
@gmail.coUTH 

Package Umariya MP 

10 1010 Pandya 
Pihu 

Sai Road 02312299
882 

8/12/90 HTUpihu@rediff
.comUTH 

Package Shiradi MHA 

 
student_fees : Table 
s_id s_fees pay_date 

1 $8,000.00  11/11/11
2 $10,000.00  9/9/11
3 $12,000.00  3/5/12
4 $20,000.00  1/2/10
5 $15,000.00  4/7/10
6 $10,000.00  2/6/10
7 $12,000.00  4/9/11
8 $12,500.00  1/3/11
9 $10,500.00  5/7/09

10 $13,000.00  9/6/10
 
 

Sports_detail : Table 
s_id sports_id game_played duration_hour playing_date 

1 S001 volly ball 25 minutes 6/1/12 
2 S002 cricket 1 Day 7/2/12 
3 S001 volly ball 30 minutes 6/6/12 
1 S002 cricket Test match 8/8/12 
2 S003 basket ball 25 minutes 8/9/12 
3 S002 cricket 1 Day 7/3/12 

 
 
Note : Close the Database “ACCESS_DB” 
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Exercise 8 : Create Query using wizard 
 

1. Open MS-Access and open Database “ACCESS_DB”. 
2. Select Query Tab from Objects form Database Window. 
3. Click on “Create query by using Wizard”. 
4. In simple Query wizard Dialogbox , select table “student” and add selected field from 

available fields and click on Next. 
 

 
 
5. Without change click Next. 

 

 
 

6. Type name of Query “student_wizard_query” and click Finish. 
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Exercise 9: Create Select Query  
 

1. In  Database window click Queries under Objects . 
2. Click on “Create Query in Design View”. 
3. In show table dialogbox select “student “ table and click on Add. 
4. Close show table Dialogbox. 
5. Add s_no,s_name and city fields to QBE Grid. 
 

 
 
6. Click on Run Button from toolbar. 
7. Save the Query named “student_select” 
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Exercise 10 : Create Different Action Queries. 
 

 Append Query 
 

1. Create table “Append_student” using following structure. 
 

Append_student :table 
FieldName Data Type description 
s_no Number Student number 
s_name Text Student name 
State Text  State of student 

Note : Do not enter records in Append_student table 
 
2. In  Database window click Queries under Objects . 
3. Click on “Create Query in Design View”. 
4. In show table dialogbox select “student “ table and click on Add. 
5. Close show table Dialogbox. 
6. Add s_no,s_name and state fields to QBE Grid. 
7. From Query menu select Append Query. 

 

 
 
8. In appeared dialogbox ,Choose “Append_student” table form dropdown list  
 

 
 
9.  Click Ok. 
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10.  You can see additional row  “ Append To “ in QBE Grid 
 

 
 
11.  Click Run button from toolbar ,click on Yes in dialog box 

 

 
 

12. Save Query named “student_append” 
13. Close the Query window. 
14. To View result for this Query ,From Table tab open “Append_student” table 

 
 Delete Query 

 
1. In  Database window click Queries under Objects . 
2. Click on “Create Query in Design View”. 
3. In show table dialogbox select “marksheet “ table and click on Add. 
4. Close show table Dialogbox. 
5. Add “std_id” field to QBE Grid. 
6. From Query menu select Delete Query. 
7. You can see additional row “Delete” in QBE Grid. 
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8. Type condition >4 in criteria row. 
9. click on Run button and click yes in dialogbox. 
 

 
 
10. Save Query named “marksheet_delete”. 
11. Close the Query window. 
12. To View result for this Query ,From Table tab open “marksheet” table 
 
 

 Update Query 
 

1.  In  Database window click Queries under Objects . 
2. Click on “Create Query in Design View”. 
3. In show table dialogbox select “marksheet “ table and click on Add. 
4. Close show table Dialogbox. 
5. Add mark1,mark2,mark3 and total  fields to QBE Grid. 
6. From Query menu select Update Query. 
7. You can see additional row “Update To” in QBE Grid. 
8. In total column Right click on  
9. Update To row  select Build . 
 

 
 

10.  In Expression Builder specify condition as follow. 
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11. Click ok. 
12. Click on Run Button and click Yes. 

 

 
 
13. Save Query named “marksheet_update” 
14. Close the Query window. 
15. To View result for this Query ,From Table tab open “marksheet” table 
 

 Make-Table Query 
 

1. In  Database window click Queries under Objects . 
2. Click on “Create Query in Design View”. 
3. In show table dialogbox select “student “ and “sports_details”  tables and click on Add. 
4. Close show table Dialogbox. 
5. Add “s_no and s_name” fields of student table , Add “game_played” field of 

sports_detail to QBE Grid. 
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6. From Query menu select Make Table Query. 
7.  In Make Table Dialog box ,Type New Table name “maketable_student_sports” and click 

Ok. 

  
  
8. Click on Run Button and Click Yes. 

 

  
 
9. Save Query named “student_sports_maketable”. 
10. Close the Query window. 
11. To View result for this Query ,From Table tab open “maketable_student_sports” table 
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Exercise 11 : Create query using CrossTab Query Wizard. 
 

 Cross Tab Query 
1.  Create “Product” Table with following records . 
 

Product : Table 
company product sale 
colgate toothpaste 5000
HLL soap 9000
HLL toothpaste 8000
johnson soap 4000
britania biscuit 8000
Parle biscuit 8000
johnson toothpaste 4500
colgate soap 8500

  
2. In  Database window click Queries under Objects . 
3. Click on New button in Database window and select CrossTab Query Wizard. 
 

 
 
4.  Select “Product” Table and click Next. 
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5.  Select “product” field and click next. 

 

 
 
6.  Select “company” field and click Next. 
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7.  Select “sale” field and “Sum” from functions List and click Next 
 

 
  
8.   Click Finish 
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9. You can see Result like this. 
 

 
 

 Find Duplicate Query 
 

1. In  Database window click Queries under Objects . 
2. Click on New button in Database window and select Find Duplicates Query Wizard. 
 

 
 
3.  Select “student” table from Dialogbox and click Next. 
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4. Select “city” for find duplicate value and click Next. 
 

 
 
 

 
5. Select Additional fields for Query and click Next. 
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6.  Click Next without change and click Finish. 

 

 
 
7. Result for above query.  
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Exercise 12 : Create Parameter Queries. 
 

1. In  Database window click Queries under Objects . 
2. Click on “Create Query in Design View”. 
3. In show table dialogbox select “student_fees “  table and click on Add. 
4. Close show table Dialogbox. 
5. Add “s_id and s_fees” fields of student_fees table to QBE Grid. 
6. Type >=[enter fees] in criteria row. 

 

 
 
7. Click Run and you will get following Dialog box and write your parameter and click Ok. 
 

 
 

8. Now you will get out put and save query named “student_fees_parameter” . 
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